Cara Setting Email Gmail Via Winbox & Script Di Mikrotik


Setting Email Gmail di mikrotik, mengirim email di mikrotik, mencatat aktifitas email di mikrotik, membuat notifikasi otomatis status server Down/Up ke email.

Hai sobat Blues Pedia, pada tutorial kali ini kita akan belajar Cara Setting Email Gmail Via Winbox & Script Di Mikrotik, Sebelum anda memulai tutorial ini, pastikan anda mengetahui data email yang akan di gunakan, seperti IP Address dan port yang di gunakan, bagi anda yang menggunakan Gmail, tidak perlu khawatir karena pada tutorial ini saya menggunakan gmail, tinggal menyesuiakan saja.
Sekarang Ada Videonya | Durasi 05:13
Konfigurasi Email Gmail & Mengirim Email Di Mikrotik
A. Setting Email Di Mikrotik
1. Persiapan
Sebagai langkah persiapan ada hal yang harus di lakukan, yaitu mengubah pengaturan akun google yang di gunakan, agar akun tersebut bisa di gunakan di semua perangkat, seperti Mikrotik, caranya klik link di bawah ini yang akan mengarahkan anda pada settingan security Google :

Pada halaman tersebut secara default pengaturan akun gmail anda dalam keadaan Off, maka aktifkanlah dengan cara pilih option Turn On.  Namun sebelum anda mengaktifkanya baca terlebih dulu pesan yang ada di sana dengan baik ya.

2. Menampilkan Halaman Konfigurasi Email
Jika sudah, pada halaman utama mikrotik di winbox, klik menu Tools lalu klik Email

3. Konfigurasi Email
lalu isilah kolom yang tersedia :

Server : Isi dengan IP Address Email yang akan di gunakan
 Port : Port Email
 Start TLS : Security email yang di gunakan, apakah menggunakan TLS / tidak
 From : Nama / alamat email anda
 User : Alamat Email yang di gunakan
 Password : Password Email yang di gunakan.
➥ Jika sudah Klik OK

4. Setting Email Di Mikrotik Via Script
Untuk versi scriptnya tuliskan saja script berikut :
/tool e-mail set address=[:resolve smtp.gmail.com] from=<alamat_email@anda.com> password=password_email port=587 start-tls=yes user=alamat_email@anda.com
untuk versi script, ada yang berbeda pada pengaturan addressnya, yaitu kita tidak menuliskan IP Address email yang di gunakan, melainkan script [:resolve smtp.gmail.com], script tersebut berfungsi untuk menentukan IP address gmail secara otomatis.

B. Mengirim Email Di Mikrotik
Setelah selesai konfigurasi email di mikrotik, langkah selanjutnya sebagai pengetesan cobalah untuk mengirim email lewat mikrotik, caranya :

1. Menampilkan Halaman Pengiriman Pesan
Pada halaman utama mikrotik, klik Menu Tool > Email > lalu klik navigasi Send Email

2. Isi Data Yang Di Butuhkan

➥ Address : IP address email
➥ Port : Port email
➥ User : Alamat email
➥ Password : Password email
➥ Tandai TLS (tergantung dari security yang di gunakan)
➥ TO : Alamat email penerima
➥ CC : Alamat email penerima
➥ From : Nama / Alamat email pengirim
➥ Subject : Judul dari Email
➥ Body : Pesan Email yang akan di kirimkan
➥ File : Pilih file yang ingin di kirimkan sebagai lampiran
Jika sudah lengkap, klik send email untuk mengirimkan pesan

3. Mengirim Email Via Script
Sedangkan untuk versi scriptnya :
/tool e-mail send to=alamat_email@penerima.com subject="Kirim Email Via Mikrotik" body="SUKSES !" start-tls=yes file=BluesPedia.backup
penjelasan script diatas, saya mengirim email ke alamat_email@penerima.com dengan subject "Kirim Email Via Mikrotik", isi pesan Sukses, menggunakan tls dan melampirkan file backup dengan nama BluesPedia

4. Cek Inbox Email
Untuk mengecek berhasil / tidaknya, cobalah cek inbox email anda, pastikan ada email masuk, contohnya seperti ini :

C. Mencatat Aktifitas Email Di Mikrotik
Selain mengirim email, mikrotik bisa kita gunakan untuk melihat aktifitas / log email, caranya :
1. Via Winbox
Klik menu System > logging > lalu klik tanda +, lalu isi kolom Topics dengan E-mail dan kolom action dengan memory, jika sudah klik OK

2. Via Script
untuk scriptnya tuliskan saja script berikut :
/system logging add topics=e-mail action=memory
3. Mengecek Aktifitas Email
Sedangkan untuk mengecek aktifitasnya, klik menu Log

D. Monitoring IP DNS Server Google Dengan Email
Hal lain yang bisa kita lakukan dengan fitur email adalah monitoring status DNS Google,
mengapa saya memilih DNS Goolgle ?, kenapa tidak yang lain, alasanya sangatlah simple, karena saya menggunakan produk google, yaitu gmail. untuk membuatnya berikut caranya :

1. Menggunakan Winbox
Klik menu Tools > Netwatch > klik tanda +, untuk menambahkan konfigurasi, setelah itu pada :

a. Tab Host
Isi data yang di minta, contohnya seperti ini :
b. Tab Up
Sedangkan untuk Tab Up isi dengan script :
/tool e-mail send to=alamat_email@penerima.com subject="Router | DNS Google UP!" body="DNS Google UP" start-tls=yes

fungsi dari script di atas adalah untuk memberikan notifikasi yang akan di kirimkan melalui email, jika DNS sedang Up.

c. Tab Down
tidak jauh beda dengan Up, hanya berbeda pada subject dan isi dari pesan yang akan di kirimkan saja, berikut scriptnya :
/tool e-mail send to=alamat_email@penerima.com subject="Router | DNS Google Down!" body="DNS Google Down !" start-tls=yes

2. Menggunakan Script
sedangkan untuk via script, tuliskan saja script berikut :
tool netwatch add host=8.8.8.8 interval=10s timeout=1s up-script="/tool e-mail send to=alamat_email@penerima.com subject=\"Router | DNS Google UP!\" body=\"DNS Google UP\" start-tls=yes" down-script="/tool e-mail send to=alamat_email@penerima.com subject=\"Router | DNS Google Down!\" body=\"DNS Google Down !\" start-tls=yes"
Untuk keseluruhan script bisa anda copy / download di sini :
https://drive.google.com/file/d/0B257iZePQCRscE5pVE9fSEZjOGM/view?usp=sharing
itulah pembahasan mengenai cara setting email di mikrotik, cara kirim email, mencatat log email dan membuat notifikasi Up/Down IP DNS Server, untuk tutorial selanjutnya akan saya bahas cara membackup konfigurasi mikrotik dan mengirimnya langsung ke email secara otomatis, Sekian dan terima kasih.


Bantu kembangkan Blues Pedia yuk, caranya share artikel ini :

G+



1 Response to "Cara Setting Email Gmail Via Winbox & Script Di Mikrotik"

  1. Anonymous08:59

    Tutorialnya sip, dilengkapi script sama winboxnya segala

    ReplyDelete